Access数据库培训
网站公告
·Access快速平台QQ群号:189307860    ·Access快速开发平台下载地址及教程    ·欢迎添加微信交流账号:Accessoft7    ·如何快速搜索本站文章|示例|资料!    
您的位置: 首页 > 技术文章 > Access开发平台

Access快速开发平台低版本升级到最新版本出现Error#-2147319779 方法'CurrentDb'作用于对象'_Application'时失败的解决方法

时 间:2018-07-11 11:14:57
作 者:麥田   ID:11  城市:上海  QQ:3002789054点击这里给麥田发消息
摘 要:Access快速开发平台低版本升级到最新版本出现Error#-2147319779 方法'CurrentDb'作用于对象'_Application'时失败的解决方法
正 文:

一、问题描述:
      使用Access快速开发平台2.4.1版本或者其他更低的版本开发的软件,需要升级到最新版2.4.3平台上,在最新版程序文件夹中找到 RDPUpdate 文件,双击运行后,执行升级操作,出现Error#-2147319779 方法'CurrentDb'作用于对象'_Application'时失败的错误,如下图:
点击图片查看大图

二、解决方案:
      这个是代码里面DAO未引用的问题引起的,把Microsoft DAO 3.6 Object Library项引用打上勾即可,如下图:


如出现名“称与已存在的模块、工程或对象冲突”的提示,则将Microsoft Office 14.0 Access database的被打钩项勾去,然后再重新勾选Microsoft DAO 3.6 Object Library项,如下图:


Microsoft DAO 3.6 Object Library项即可引用上,再点确定按钮后,然后再重新点文件夹里面的 RDPUpdate 文件,双击运行,该问题即可解决。



Access快速开发平台QQ群 (群号:189307860)       access源码网店

最新评论 查看更多评论(0)

发表评论您的评论将提升作者分享的动力!快来评论一下吧!

用户名:
密 码:
内 容:
 

常见问答

技术分类

相关资源

关于我们 | 服务条款 | 在线投稿 | 友情链接 | 网站统计 | 网站帮助